Back to overview
Downtime

Bloxora Website

Aug 11 at 01:01pm EDT
Affected services
bloxora.com

Resolved
Aug 11 at 04:38pm EDT

Our provider has restored services, the website is now operating as intended.

Updated
Aug 11 at 01:56pm EDT

We have identified the root cause of the issue. Our host provider is down, we are working with them for an ETA on when service will be restored.

Created
Aug 11 at 01:01pm EDT

We're aware of reports of Internal Server Error. We are working with host to quickly resolve this issue and continue to provide periodic updates as more information becomes available.